AVocation Systems User Forum
http://avocationsystems.com/forum/

hdcp or edid issue??
http://avocationsystems.com/forum/viewtopic.php?f=3&t=8
Page 1 of 1

Author:  gerryh [ Tue Apr 09, 2013 8:28 pm ]
Post subject:  hdcp or edid issue??

I am continually having to try to sort out HDMI problems that seem to be either EDID or HDCP issues. Is it possible to determine which issue is causing the problem? I've seen and used some of the EDID emulators and recorders with mixed results but so far I haven't seen any fix for a HDCP problem. Any recommendations??
Thanks.
Gerry

Author:  avocationsys [ Wed Apr 10, 2013 3:26 pm ]
Post subject:  Re: hdcp or edid issue??

Thanks for the inquiry, Gerry. Our HDMI switches have a debug mode you can turn on that will give you more information about what's going on in your system. We can usually determine what's happening from that.

Our units have been to Plugfest, which is a compliance and interoperability program that tries to ensure all of these products will work together in a distributed environment. Our units have tested positive (operable) with 99% of the brands that participated, which is most of the well-known brands in our industry.

That doesn't mean there still aren't problems. Apple seems to have done a poor job implementing HDMI, and thus every once in a while we'll have problems with a mac-mini or something along those lines. Certain receivers can also be a problem child from time to time.

We've figured out ways make the apple products work specific to our products, but the receivers are another issue. Some dealers have also used emulators, like you mentioned, but the feedback we've gotten on those has been mixed as well. If that option fails, the only other remedy seems to be swapping it out with a different model number. Often times a different model number within the same brand will do the trick. We don't know why that is. HDMI is just finicky that way.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/